Alpha 3: Spawning in 4th? Biome, cannot get back. Save Broke

Post Reply
Lucidius
Posts: 2
Joined: Sat Jan 03, 2015 2:50 am

Alpha 3: Spawning in 4th? Biome, cannot get back. Save Broke

Post by Lucidius » Sat Jan 03, 2015 3:08 am

Ver: Alpha 3
Short Description: After getting Hideout 3 I died and respawned the next day outside the bounds of Old Woods in what I can only assume is 4th biome.
Loaded Before: Yes
Day: 45 :/ (goodbye good run)

Details:

The third day or so exploring the Old Woods I finally found Hideout 3. Prepared, I had brought a bucket and used it to repair the well there. I may or may not have attempted to drink from the well afterwards (which would have said ofc it was not yet time)...and proceeded to explore the place (my first time finding it, I was ecstatic).

However the hour was late and rather than try to hole up with nearly zero preparations, I opted to dump what I could in Wardrobes and try to run back to fortified Hideout 2. Unfortunately it got pretty dark and I never even made it out of the Old Woods, having to face a red chomper in the dark and after slaying it, nearly dead, I ran on a mushroom in a panic. I immediately went into inventory to switch an item out with batteries on my hotbar, but died while still left-clicked -> 'holding' batteries while accessing inventory.

Wake up the next day in what was described as 'Old Woods' (on top of screen) and proceeded to run away from the wall in hopes of finding a landmark. Instead what I find is a black block of 'nothing' that I can walk through and over, which continues indefinitely. There is nothing else except normal ground near the 'wall' which I trace in hopes of finding something. On the other side of the wall, I can see the big trees that Old Woods has...somehow. Still not sure where I am, I sit on a molotov in hopes of spawning in a legit spot, only to find that I spawn in the same exact spot as before. I can see my 'lost inventory' as outside the bounds of the Old Woods biome.

So here I am, a 45day broken save, pretty frustrated. Literal game-breaking bug to be sure.

As a programmer, I have a couple ideas that might help:

* My fixing the Hideout 3 well but then dying before actually using it.
* Attempted use of the well after fixing it but not actually drinking from it before dying.
* Dying while accessing inventory while having item 'in hand' (left click on item in inventory)
* Dying near the border of Old Woods and Forest

Attached is the output_log.txt file suggested.
Attachments
output_log.txt
(48.39 KiB) Downloaded 124 times

Post Reply